当前位置:首页 > 问答

通达信副图选股博客

我来帮TA回答

通达信副图,想让每个选股公式在出信号的同时右边都有文字显示,如何编写呢?

想法挺奇妙

1、将几个信号合成到一个选股公式里面,这个能够实现。

2、不同的信号不同的颜色和文字表示出来,这个也能做到。

我只举几个例子,以图为例

请老师将我的通达信副图做出选股公式,副图公式如下。

你这个主图里有很多指标,你想用哪个指标选股?

通达信副图公式请老师帮忙改成选股公式

H1:=REF(HIGH,1);

L1:=REF(LOW,1);

D1:=HIGH>H1 AND LOW>=L1

AND CLOSE>REF(CLOSE,1);

D11:=HIGH>H1 AND LOW>=L1

AND CLOSE<=REF(CLOSE,1);

D2:=LOW<L1 AND HIGH<H1;

D3:=HIGH>H1 AND LOW<L1

AND CLOSE>REF(CLOSE,1);

D31:=HIGH>H1 AND LOW<L1

AND CLOSE<=REF(CLOSE,1);

D4:=HIGH<=H1 AND LOW>=L1;

FR1:=SUM(IF(D1,HIGH,IF(D11,LOW,IF(D2,-HIGH,IF(D3,

HIGH,IF(D31,-HIGH,IF(D4,0,0)))))),0)/100;

XG:REF(FR1<REF(FR1,1),1) AND FR1>=REF(FR1,1);

通达信副图指标改成选股公式

买入:=(2*CLOSE+HIGH+LOW)/4;
不急:=EMA(买入,4);
获利:=EMA(不急,4);
不贪:=EMA(获利,4);
准赚:=(不贪-REF(不贪,1))/REF(不贪,1)*100;
XG:CROSS(XMA(L,8),MEMA(O,2));


注意这指标有未来函数

请高手将这个通达信幅图改成出现“黑马”的选股公式 源码好长 我分二次发

你做个文本文件,作为附件不就行了吗

请高手将这个通达信幅图改成出现“黑马”的选股公式

多空线:=SMA((O+CLOSE+HIGH+LOW)/4,3,1); 强命线:=EMA(COST(81),10); CTX:=(3*C+H+L+O)/6; IONG:=(8*CTX+7*REF(CTX,1)+6*REF(CTX,2)+5*REF(CTX,3)+4*REF(CTX,4)+3*REF(CTX,5)+2*REF(CTX,6)+REF(CTX,8))/36; CTXIONG:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>IONG AND C>O; XG:=FILTER(CTXIONG,5); BB1:=CROSS(多空线,强命线); VBR1:=EMA(CLOSE,8); VBR2:=EMA(CLOSE,20); YA:=IF(C>=O,AMOUNT,0); YAOBV:=SUM(YA,0); MOBV:=SUM(AMOUNT,0); BL:=100*YAOBV/MOBV; MABL3:=IF(BARSSINCE(C)>=3,MA(BL,3),50); MABL30:=IF(BARSSINCE(C)>=30,MA(BL,30),MABL3); SSS3:=COUNT(CROSS(VBR1,VBR2),10)>=1; SSS4:=COUNT(CROSS(MABL3,MABL30),10)=1; 黑马:COUNT(XG,5)>=1 AND BB1 AND SSS3 AND SSS4;